Full Changelog

11.1.2 released December 7, 2018

  • Fixed an issue with the cell selection clearing after clicking a row or column and then copying the cells.
  • Fixed a crash calculating the FDS for designs with a centroid outside the regular space.

11.1.1 released November 29, 2018

  • Increased limit on numeric factors in historical designs.
  • Fixed incorrect scaling of half-normal plot when subplot pure error is very small.
  • Opening a file immediately after changing the decimal separator will no longer result in an error.
  • Fixed crash while printing from macOS.
  • Selecting cells with the shift+arrow keys now works as expected.
  • Added email activation dialog when internet activation fails.
  • When the cursor is over a combo box in a grid the initial keypress will select an element in the list.
  • Pressing tab when on a combo box in a grid will now go to the next cell.
  • Fixed a bug where clicking a column header after returning from another program prevented pasting.

11.1.0 released July 11, 2018

  • Initial release on macOS.
  • Fixed grid focus issue that was preventing pasting data after returning from another program (e.g. Excel).
  • The license agreement now appears on first execution of the program, rather than in the installer.

11.0.6 released June 27, 2018

  • Fixed issues entering FDS data in non-US locales.
  • Enabled pasting of response and factor names and units in the Column Info sheet view.
  • Fixed crash selecting the Trace plot in Numerical Optimization.
  • The choice to view Variance on the Evaluation plots has been moved to the View menu.
  • Warnings and footnotes in reports can now be toggled via the tab menu.
  • Added “Copy All” to the Diagnostics Edit menu, which copies all the graphs to the clipboard.
  • Axis lows and highs can now be edited from the “Sheet…” dialog.
  • The Factor and Response Format field can now be manually entered.
  • Fixed a bug causing the graph legend to disappear when a non-standard character is in the response name.
  • The Factors Tool now appears for designs with one or fewer factors.
  • The Real contour plot is now available for combined designs where the mixture portion has exactly 3 factors.
  • Response and Block input tables can now be transposed.
  • When the optimization cannot find any solutions a report is now presented with a link to help.
  • The Box-Cox graph no longer has squares along the line.
  • Restored the XML filetype to the Design Layout “Export to File…” filetype list.

11.0.5 released March 26, 2018

  • You can now maximize a tab by selecting “Expand/Shrink Tab” from the tab menu.
  • Enabled copy/paste for the contrast table when editing a categoric factor.
  • Opening a file directly from File Explorer will no longer truncate data in non-US locales.
  • Fixed a bug causing incorrect contour values for certain locales with a thousand separator.

11.0.4 released February 21, 2018

  • Optimization criteria can now be entered in Transformed or Original scale on a per-response basis.
  • File association icons should now appear properly in Windows Explorer.
  • Fixed a bug preventing the Design Wizard from working after it has run once in a session.
  • The number localization preference dialog will no longer appear every time the program starts.
  • Exponential notation can now be used in the Design Layout.

11.0.3 released December 20, 2017

  • Paths that contain unicode characters will now load.
  • Fixed a bug preventing panning in the Y-axis direction on some graphs.
  • Fixed simulator errors when using a comma as a decimal separator.
  • Manual contour settings will now be saved when using a comma as a decimal separator.
  • Fixed crash when editing the Graph Columns axes when a non-editable axis is present (e.g. Runs).
  • Factorial augment now defaults to D-optimal.
  • The “Default Data Path” preference now works properly.
  • The X matrix will now display in Actuals or Reals if selected in Evaluation.
  • The Preferences dialog will no longer start off screen on lower resolution displays.

11.0.2 released December 7, 2017

  • Fixed crash when checking for updates in the 32-bit version.
  • Added preference for the color of design points below the 3d surface.
  • Invalid bounds in the optimization criteria will now show a warning message.
  • Fixed run variation setting not being set when rebuilding a desgin.

11.0.1 released November 30, 2017

  • Removed translation catalog warning on program start.
  • Enabled tab and enter in the property grid controls.
  • Fixed bug where the File menu is disabled after closing during the design build.
  • Removed invalid model terms when opening an old file with curvature.
  • Fixed legend font changing when the factor name starts with a pound symbol.
  • Improved tick labels in the Mix-Mix contour plot.
  • Values pasted with a decimal separator other than ‘.’ will no longer be truncated.

11.0.0 released November 15, 2017

User Interface

  • The look-and-feel has been updated including new icons and more tooltips.
  • Toolboxes (e.g. the Factors Tool) can be docked and resized.
  • Better scaling on high dps displays.
  • The Design Layout displays a Design Properties tool that allows interactive editing of row and column attributes.
  • Graph legends are separate windows that can be docked next to the graph.
  • Unicode and UTF-8 character sets are now supported.
  • The Run Sheet view of the design has been eliminated to reduce clutter.
  • Confirmation runs are now stored in separate tabs.
  • Factor settings set in Point Prediction will carry through to the Confirmation node.
  • The Coefficients Table shows terms up to second order, even if they were not selected in any response analysis.
  • Footnotes now link directly to help topics.
  • Changing group numbers in a split-plot design no longer results in constant group level warnings. One check for group consistency is done as you leave the design layout.

Reports

  • Reports have been split into separate tabs that can be resized and rearranged.
  • There is a new toolbar for switching between predetermined layouts for the tabs.
  • Factorials with center points now have a curvature test with an interactive “Remove/Add Curvature” button.
  • Many tables in reports are now sortable.
  • Ctrl–scrollwheel zooms in/out of reports, increasing/decreasing the font size.

Graphs

  • The Diagnostics plots have been split into separate tabs that can be resized and rearranged.
  • Reduced the density of the 3d grid, which prevents the Moiré effect at high resolutions.
  • Discrete factors now use a combobox in the Factors Tool rather than a slider.
  • The Box-Cox plot shows the current transform in the legend.
  • Improved UTF-8 support for graph labels.
  • Copying a graph will now give the option of copying in Enhanced Metafile format.

Build

  • Split-Plot designs can be built with I or A-optimal criteria
  • Split-Plot factorial design sizes are now specified by number of groups and group size.
  • Optimal bootstrap parameters have been tweaked to improve performance.
  • You can now cancel the “Adding Candidate Points” progress dialog.
  • Improved the presentation of the Design Wizard dialogs.
  • The design augmentation feature now honors discrete numeric levels.

Simulator

  • The “Generate Random Model” button now generates much more sensible models.
  • The response simulator has been expanded with new functions and constants (see help for usage).

Analysis

  • The maximum model order in the Fit Summary can now be limited to speed up calculations for large designs.
  • The ANOVA for factorials with center points has been streamlined to make it the analysis more intuitive and flexible.

Miscellaneous

  • Files with unicode characters in the name are now loaded properly.
  • Many more bug fixes and interface tweaks.